grootste waarden optellen in Excel

Grootste waarden optellen in Excel

Je kunt eenvoudig de tien grootste waarden optellen in Excel, een klusje dat best eens van pas komt zo af en toe. Onderstaande tip is afkomstig uit mijn boek Excel aan het werk, functies voor wiskunde en statistiek.

De tien grootste waarden optellen in Excel is snel te realiseren en komt best van pas. Stel, je hebt verkoopcijfers (of scores) en je wilt daar de tien grootste waarden uit halen en die optellen. Dat gaat niet met SOM.ALS, maar wel met SOMPRODUCT.

In het volgende voorbeeld staan de waarden onder elkaar in B2 tot en met B24. Je formule is:

=SOMPRODUCT(GROOTSTE(B2:B24;RIJ(1:10)))

Deze zoekt automatisch de tien grootste waarden uit het gebied en telt die op.

Hier verwijst RIJ niet naar de gewone rijnummers in het werkblad, maar in het geheugen wordt een eigen tabel aangemaakt en daarvan worden de rijnummers gebruikt.

Verfijnen

Als er nog geen tien waarden zijn ingevoerd, zal deze formule de foutmelding #GETAL! geven, omdat er nog geen toptien is. Dat vang je op met een ALSformule. Die kijkt eerst of het aantal getallen kleiner is dan 10; en telt in dat geval al die waarden op met:

=ALS(AANTAL(B2:B24)<10;SOM(B2:B24))

Zijn er meer dan tien waarden, dan worden de tien grootste opgeteld. Je complete formule is:

=ALS(AANTAL(B2:B24)<10;SOM(B2:B24);SOMPRODUCT(GROOTSTE(B2:B24;RIJ($1:$10))))

grootste waarden optellen in Excel
Je kunt met SOMPRODUCT de tien grootste waarden uit een hele serie optellen.
grootste waarden optellen in ExcelGebruik SOMPRODUCT niet te vaak

In het boek Excel aan het werk, functies voor wiskunde en statistiek vind je meer voorbeelden met SOMPRODUCT. Als je een groot aantal formules met de functie SOMPRODUCT in je werkblad plaatst, zal je werkblad trager gaan werken. Ook als formules met deze functie een groot gebied moeten doorzoeken, kost dat tijd. Het is in dat geval verstandiger om een draaitabel op te zetten (zie Gegevens verwerken in Excel, hoofdstuk 8).

Meer tips en trucs van Wim de Groot? Op dit blog zijn er veel te vinden. Al zijn Excel-tips, plus interviews met Wim vind je HIER.

Wiskunde en statistiek in Excel

Wiskunde en statistiek in ExcelNog veel meer weten over het gemiddelde berekenen in Excel? Lees dan mijn boek Excel aan het werk, functies voor wiskunde en statistiek. Daarin worden honderd rekenfuncties van Excel besproken op het gebied van wiskunde en statistiek. Die worden uitgelegd aan de hand van voorbeelden. Je leert hoe je een functie gebruikt, zodat je die kunt toepassen in je eigen werk, studie of hobby.

Nadat je hebt gezien hoe je een formule samenstelt, ga je de diepte in. Tot de behandelde onderwerpen behoren:

  • optellen, tellen en gemiddelde berekenen
  • totaal, aantal en gemiddelde voor een beperkte groep berekenen en op meer criteria
  • afronden in allerlei stappen
  • werken met breuken en logaritme
  • willekeurige getallen trekken
  • kansen en standaardafwijking berekenen
  • getallen in groepen verdelen met statistische functies
  • correlatie, trend en regressie tussen getallenreeksen vinden

Dit boek is te gebruiken met Excel 2010 tot en met 2019 (en Microsoft 365).

Je kunt negentig gratis oefenbestanden bij dit boek downloaden. In de ene helft staan alleen de gegevens zodat je zelf aan de slag kunt, in de andere helft van de bestanden zijn de voorbeelden helemaal uitgewerkt.


Goed om te zien dat het artikel je tot het einde toe heeft kunnen interesseren. De meeste artikelen op dit blog worden geschreven door de auteurs van uitgeverij Van Duuren MediaBen je geïnteresseerd in verdere verdieping of meer praktische toepassingen? Klik op onderstaande banner voor het meest actuele overzicht.

Geef een reactie

Deze website gebruikt Akismet om spam te verminderen. Bekijk hoe je reactie-gegevens worden verwerkt.