de functie TEKST in Excel

De functie TEKST in Excel

De functie TEKST in Excel geeft een waarde weer als tekst in de opmaak die u opgeeft. En dat biedt leuke en handige mogelijkheden. Hieronder bespreek ik deze functie, in mijn boek Het complete boek Excel voor professionals, 5e editie. Vanzelfsprekend treft u nog veel en veel meer diepgravende tips en trucs aan voor dit ‘ultieme’ spreadsheetpakket van Microsoft.

🖋️ Syntaxis van TEKST

=TEKST(waarde; “opmaakcode”)

De waarde is een getal, tijdstip, datum of percentage dat u wilt omzetten naar tekst; met de opmaakcode tussen dubbele aanhalingstekens bepaalt u de weergave.
Resultaat: het getal in een bepaalde opmaak.

Wilt u een bepaalde waarde in een zin opnemen, dan zal dat standaard als een getal worden weergegeven. Dat gebeurt ook met een tijdstip. U wilt bijvoorbeeld met de functie NU de zin samenstellen: ‘Het is nu 12:00’ als het op dat moment 12:00 uur is. U voert de formule in:

=”Het is nu “&NU()

Als het 1 juli 2020 12:00 is, zal dit resulteren in ‘Het is nu 44013,5’. Om het tijdstip in deze zin als 12:00 weer te geven, gebruikt u de functie TEKST in combinatie met een opmaakcode:

=”Het is nu “&TEKST(NU();”uu:mm”)

Nu staat er om 12 uur ’s middags wel ‘Het is nu 12:00’.

Opmaakcodes

Bij de functie TEKST bepaalt u met een opmaakcode hoe het getal wordt weergegeven. In de tabel vindt u enkele opties.

de functie TEKST in Excel
  • De opmaakcodes die u hier kunt gebruiken, zijn dezelfde als die u in het venster Celeigenschappen, in het tabblad Getal onder Aangepast kunt opgeven. Alleen moet u in de functie TEKST de opmaakcode tussen dubbele aanhalingstekens plaatsen.
  • Meer voorbeelden van opmaakcodes vindt u in elders in het boek.

💡 Opmaakcode opzoeken
Weet u de opmaakcode niet voor de weergave die u wenst, maak dan een getal in een andere cel naar wens op. Open het venster Celeigenschappen (sneltoets: Ctrl+1). Klik in het tabblad Getal op Aangepast en u vindt de opmaakcode onder Type. In het vak daaronder kunt u bladeren om meer ideeën op te doen.

Zo kunt u ook de weergave van de datum in een zin naar uw hand zetten. Als het bijvoorbeeld 1 juli 2020 is en u wilt dat er op die dag verschijnt ‘Het is vandaag 1 juli’, dan neemt u:

=”Het is vandaag “&TEKST(NU();”d mmmm”)

Wilt u het tijdstip er ook bij weergeven, zodat u om twaalf uur ziet ‘Het is nu 1 juli 2020 12:00’, dan gebruikt u:

=”Het is nu “&TEKST(NU();”d mmmm jjj uu:mm”)

  • Zolang er geen woorden in de uitkomst staan, kan Excel ermee verder rekenen, bijvoorbeeld een aantal uren of dagen erbij optellen.

Wilt u de waarde van een halve dag (0,5) weergeven als een tijdstip, dan neemt u die waarde in de formule op:

=TEKST(0,5;”u:mm:ss”)

U ziet dan ‘12:00:00’.

  • Staat deze 0,5 in een cel, dan kunt u die cel ook meteen opmaken als Tijd. Ook dan ziet u 12:00:00.

In de volgende formule kunt u een koers die in B3 als een decimaal getal staat, gewoon in die vorm meenemen. De formule is:

=”Onze koers is vandaag “&B3&”.”

Vergelijkt u in C3 hoeveel procent B3 is ten opzichte van de beginstand in B1 met:

=B3/B$1-1

en wilt u dat percentage in de zin opnemen, dan gebruikt u TEKST en de opmaakcode “0,0%”:

=”Onze koers is vandaag “&B3&”, we staan op “&TEKST(C3;”0,0%”)

  • U kunt de berekening van het percentage ook in de formule zelf opnemen:

=”Onze koers is vandaag “&B3&”, we staan op “&TEKST(B3/B$1-1;”0,0%”)

Het complete boek Excel voor professionals,5e editie is bedoeld voor mensen die de basisvaardigheden van Excel onder de knie hebben en de uitgebreide mogelijkheden van dit programma verder willen benutten. In dit boek legt Wim de Groot in zijn bekende heldere stijl uit wat je met Excel kunt, zonder te vervallen in technisch jargon. In dit boek staan zo’n 1500 formules als voorbeeld. Bij elke formule legt Wim de Groot uit hoe deze werkt, zodat je de voorbeelden kunt gebruiken in je eigen situatie. Hij bespreekt 255 functies, ruim de helft van alle functies die Excel heeft. Het complete boek Excel voor professionals is hét standaardwerk voor Excel!

Meer tips over Microsoft Excel:

  • lijngrafiek tekenen in Excel
    Lijngrafiek tekenen in Excel

    Er zijn allerlei mogelijkheden om ‘saaie’ data te visualiseren, bijvoorbeeld middels een lijngrafiek tekenen in Excel.

    Lees hier verder…

  • code optimaliseren in Excel VBA
    Code optimaliseren in Excel VBA

    Door aan de slag te gaan met code optimaliseren in Excel VBA verkort u deze niet alleen, maar maakt u ‘m ook sneller. Onderstaand fragment is afkomstig uit Het complete Boek Excel VBA voor professionals, 4e editie.

    Lees hier verder…

  • macro’s in Excel
    Macro’s maken en gebruiken in Excel

    Met macro’s in Excel kunt u allerlei zaken op een eenvoudige manier automatiseren door ze simpelweg op te nemen en weer af te spelen

    Lees hier verder…

  • Sorteren met een dubbelklik in Excel
    Sorteren met een dubbelklik in Excel

    Wat dacht u ervan om een lijst in Excel te sorteren door te dubbelklikken ergens in de desbetreffende kolom? Dat klinkt als toveren, maar de VBA-code hiervoor is verrassend eenvoudig.

    Lees hier verder…

  • verticale as in Excelgrafiek aanpassen
    De verticale as in een Excelgrafiek aanpassen

    Excel stelt bij een grafiek zelf de grootste en kleinste waarde van de verticale as in, maar zelf de verticale as in Excelgrafiek aanpassen is ook een optie. Hoe, dat lees je hier.

    Lees hier verder…

  • cellen kleuren met voorwaardelijk opmaak in Excel
    Cellen kleuren met voorwaardelijk opmaak in Excel

    Soms wordt een tabel wat onoverzichtelijk. Cellen kleuren met voorwaardelijke opmaak in Excel brengt dan helderheid!

    Lees hier verder…


Alle tips en trucs op Computer Creatief voor Excel vind je HIER


 

Geef een reactie

Deze site gebruikt Akismet om spam te verminderen. Bekijk hoe je reactie-gegevens worden verwerkt.