de functie TEKST in Excel

De functie TEKST in Excel

De functie TEKST in Excel geeft een waarde weer als tekst in de opmaak die u opgeeft. En dat biedt leuke en handige mogelijkheden. Hieronder bespreek ik deze functie, in mijn boek Het complete boek Excel voor professionals, 5e editie. Vanzelfsprekend treft u nog veel en veel meer diepgravende tips en trucs aan voor dit ‘ultieme’ spreadsheetpakket van Microsoft.

🖋️ Syntaxis van TEKST

=TEKST(waarde; “opmaakcode”)

De waarde is een getal, tijdstip, datum of percentage dat u wilt omzetten naar tekst; met de opmaakcode tussen dubbele aanhalingstekens bepaalt u de weergave.
Resultaat: het getal in een bepaalde opmaak.

Wilt u een bepaalde waarde in een zin opnemen, dan zal dat standaard als een getal worden weergegeven. Dat gebeurt ook met een tijdstip. U wilt bijvoorbeeld met de functie NU de zin samenstellen: ‘Het is nu 12:00’ als het op dat moment 12:00 uur is. U voert de formule in:

=”Het is nu “&NU()

Als het 1 juli 2020 12:00 is, zal dit resulteren in ‘Het is nu 44013,5’. Om het tijdstip in deze zin als 12:00 weer te geven, gebruikt u de functie TEKST in combinatie met een opmaakcode:

=”Het is nu “&TEKST(NU();”uu:mm”)

Nu staat er om 12 uur ’s middags wel ‘Het is nu 12:00’.

Opmaakcodes

Bij de functie TEKST bepaalt u met een opmaakcode hoe het getal wordt weergegeven. In de tabel vindt u enkele opties.

de functie TEKST in Excel
  • De opmaakcodes die u hier kunt gebruiken, zijn dezelfde als die u in het venster Celeigenschappen, in het tabblad Getal onder Aangepast kunt opgeven. Alleen moet u in de functie TEKST de opmaakcode tussen dubbele aanhalingstekens plaatsen.
  • Meer voorbeelden van opmaakcodes vindt u in elders in het boek.

💡 Opmaakcode opzoeken
Weet u de opmaakcode niet voor de weergave die u wenst, maak dan een getal in een andere cel naar wens op. Open het venster Celeigenschappen (sneltoets: Ctrl+1). Klik in het tabblad Getal op Aangepast en u vindt de opmaakcode onder Type. In het vak daaronder kunt u bladeren om meer ideeën op te doen.

Zo kunt u ook de weergave van de datum in een zin naar uw hand zetten. Als het bijvoorbeeld 1 juli 2020 is en u wilt dat er op die dag verschijnt ‘Het is vandaag 1 juli’, dan neemt u:

=”Het is vandaag “&TEKST(NU();”d mmmm”)

Wilt u het tijdstip er ook bij weergeven, zodat u om twaalf uur ziet ‘Het is nu 1 juli 2020 12:00’, dan gebruikt u:

=”Het is nu “&TEKST(NU();”d mmmm jjj uu:mm”)

  • Zolang er geen woorden in de uitkomst staan, kan Excel ermee verder rekenen, bijvoorbeeld een aantal uren of dagen erbij optellen.

Wilt u de waarde van een halve dag (0,5) weergeven als een tijdstip, dan neemt u die waarde in de formule op:

=TEKST(0,5;”u:mm:ss”)

U ziet dan ‘12:00:00’.

  • Staat deze 0,5 in een cel, dan kunt u die cel ook meteen opmaken als Tijd. Ook dan ziet u 12:00:00.

In de volgende formule kunt u een koers die in B3 als een decimaal getal staat, gewoon in die vorm meenemen. De formule is:

=”Onze koers is vandaag “&B3&”.”

Vergelijkt u in C3 hoeveel procent B3 is ten opzichte van de beginstand in B1 met:

=B3/B$1-1

en wilt u dat percentage in de zin opnemen, dan gebruikt u TEKST en de opmaakcode “0,0%”:

=”Onze koers is vandaag “&B3&”, we staan op “&TEKST(C3;”0,0%”)

  • U kunt de berekening van het percentage ook in de formule zelf opnemen:

=”Onze koers is vandaag “&B3&”, we staan op “&TEKST(B3/B$1-1;”0,0%”)

Het complete boek Excel voor professionals,5e editie is bedoeld voor mensen die de basisvaardigheden van Excel onder de knie hebben en de uitgebreide mogelijkheden van dit programma verder willen benutten. In dit boek legt Wim de Groot in zijn bekende heldere stijl uit wat je met Excel kunt, zonder te vervallen in technisch jargon. In dit boek staan zo’n 1500 formules als voorbeeld. Bij elke formule legt Wim de Groot uit hoe deze werkt, zodat je de voorbeelden kunt gebruiken in je eigen situatie. Hij bespreekt 255 functies, ruim de helft van alle functies die Excel heeft. Het complete boek Excel voor professionals is hét standaardwerk voor Excel!

Meer tips over Microsoft Excel:

  • Excel werkblad snel kopiëren
    Excel Werkblad snel kopiëren naar een ander bestand

    U kunt een Excel werkblad snel kopiëren naar Een ander bestand. Hoe, dat leest u in deze blogpost.

    Lees hier verder…

  • maanden en weken in Excel
    Werkbladen met maanden en weken in Excel

    Werkbladen met maanden en weken maken in Excel is prima automatisch te regelen, zoals u in dit artikel kunt lezen.

    Lees hier verder…

  • de wereldtijd in Excel
    Tijdsverschillen berekenen in Excel

    Hoe laat is het op dit moment in – laten we zeggen – Shanghai? Tijdsverschillen berekenen in Excel is heel eenvoudig! In deze blogpost laat ik zien hoe je dat doet.

    Lees hier verder…

  • objectgeoriënteerd programmeren In Excel
    Objectgeoriënteerd programmeren in Excel

    Leer in dit artikel de basisbeginselen van objectgeoriënteerd programmeren in Excel (en ook wat objecten zijn).

    Lees hier verder…

  • Excel-macro genereren met ChatGPT
    Een Excel-macro genereren met ChatGPT

    ChatGPT kan niet alleen goed overweg met tekst, maar ook met code. Een Excel-macro genereren met ChatGPT blijkt verrassend goed te gaan.

    Lees hier verder…

  • leeftijd exact berekenen in Excel
    Een leeftijd exact berekenen in Excel

    Precies en snel weten hoe oud iemand precies is? Laat de leeftijd exact berekenen in Excel en houd daarbij rekening met de verjaardag!

    Lees hier verder…


Alle tips en trucs op Computer Creatief voor Excel vind je HIER


 

Geef een reactie

Deze site gebruikt Akismet om spam te verminderen. Bekijk hoe je reactie-gegevens worden verwerkt.